Accessing EasyMatch QC Data in External Spreadsheets and Databases - an05_06r

Follow

Data obtained using a HunterLab sensor and EasyMatch QC software can be used in many ways. In addition to saving data, manipulating displays, and printing while within EasyMatch QC, you can also export or transfer the data to other programs for manipulation. Several methods for doing this are described below.

Copying and Pasting to Windows Spreadsheets
Data contained in EasyMatch QC’s Color Data Table and Spectral Data Table views are already in spreadsheet format. You may copy the cells desired in EasyMatch QC and then paste them into other spreadsheet programs.

1. Configure the Color Data Table or Spectral Data Table to show the parameters, standards, and samples desired.

2. Highlight the EasyMatch QC data for copying by clicking and holding the left mouse button down while dragging the cursor across the cells desired.

(screenshot)

3. To put the cells on the Windows clipboard, click the right mouse button in the spreadsheet view and select Copy to Clipboard from the menu that appears.

(screenshot)

4. Open your Windows spreadsheet, click on any cell, and select Paste from the Edit menu to paste the data into the spreadsheet.  The example given here uses Microsoft Excel 2003.

(screenshot)

5. Manipulate the data and/or perform calculations as desired.

Opening EasyMatch QC’s Database Files Using Another Database or
Spreadsheet Program
EasyMatch QC gives you the option of saving to either a Microsoft Access or SQL Server database, and that database may be opened directly through Access/SQL in addition to through EasyMatch QC. The table titled “tSensorTypeSampleSpecData” contains the raw spectral data for each sample stored. “tSensorTypeStandardSpecData” contains the same information for each standard stored. It is this information that is then converted to color scale and index information as needed for display on your screen using formulas internal to EasyMatch QC. Only this spectral data is directly available in the database, so if you need to access color scale or index information, you will need to either copy and paste as described above or export this information as described below.
Note: For security reasons, the database may not be directly opened in Access or SQL if you are running EasyMatch QC-ER.

ASCII Export
You may directly export data from EasyMatch QC to an ASCII file that may then be opened in other programs, such as spreadsheet and database programs. The ASCII Export/Configure command in the Options menu allows you to select any color scale, color difference scale, index, spectral data, etc. information desired for export to an ASCII file. ASCII Export/Export Data in the Options menu is then used to export the chosen parameters for the standards and samples desired to an ASCII text file. Automatic export of measurements as they are made is also available. Complete instructions for this procedure are included in your EasyMatch QC User’s Manual.

Note: If you select a Tab Delimiter and use an extension such as .XLS or .CSV, your exported file may be opened directly into Microsoft Excel. If you select a Comma Delimiter and use an extension such as .CSV, your exported file may be imported into a new table in Microsoft Access 2000 or higher. 

Data Send

You may send data from EasyMatch QC directly to a communications port or IP address so long as software is available at that address to accept the data. The Data Send/Configure command in the Options menu allows you to select any color scale, color difference scale, index, spectral data, etc. information desired for sending. Data Send/Send Data in the Options menu is then used to send the chosen parameters for the standards and samples desired to the configured address. Automatic sending of measurements as they are made is also available. Complete instructions for this procedure are included in your EasyMatch QC User’s Manual.  

(screenshot)

 

(See attached pdf file for the complete article with screenshots)

Was this article helpful?
0 out of 0 found this helpful

Comments

Powered by Zendesk