Lesson #1 - Setting Up a Job Template

This tutorial provides lessons that walk you through some common procedures in EasyMatch QC.  These tutorials work through screen configuration and use sample data which may not apply to your situation.  Working through these lessons will give you a good feel for how the software operates and provide a basis for substituting your own samples and displays.  This tutorial describes setting up a job template, including choosing and configuring data views.

(Download pdf below)

Lesson 2 - Standardizing and Confirming Standardization Using the White Tile

This lesson will walk you through an example reflectance standardization for a LabScan XE.  Other instruments are standardized in slightly different fashions.  After standardization, we will confirm a reading of the white calibration tile.  Your instrument should already be attached to the computer and installed in EasyMatch QC before performing this lesson.

Note that instructions for standardization in transmittance are provided in Lesson 3.  This lesson does not apply to the ColorQuest XT.

(Download pdf file below)

Lesson 3 - Measuring in a Transmittance Mode

This lesson is appropriate only if you are using an instrument capable of measuring in transmittance.  If you are using a ColorQuest XE, ColorQuest XT, ColorQuest II Sphere, UltraScan XE, UltraScan PRO, or UltraScan VIS, proceed with this lesson.  If you are using a ColorFlex EZ, ColorQuest 45/0 LAV, LabScan XE, or MiniScan EZ, do not attempt this lesson. 

Your instrument should already be attached to the computer and installed in EasyMatch QC before performing this lesson.

Lesson 4 - Using a Hitch Standard

Hitch standardization can be used to make your instrument read samples of a particular color the same way as another instrument, improving agreement.  If a product standard has been measured on another instrument (primary readings) and color or spectral values have been assigned to it, then your instrument can be adjusted to those values (secondary readings) so that samples you read are corrected for any differences between the two instruments.

To perform a hitch standardization, you need a standard with either color values or spectral values assigned to it.  Your instrument should already be attached to the computer and installed in EasyMatch QC before performing this lesson.

(Download the pdf below)

Lesson 5 - Querying the Database to Recall or Delete Data

This lesson will step you through creating a query that can be use over and over to find and delete these samples with a common thread.  One example would be samples that are more than two weeks old and measured in RSIN, but no longer needed.

(Download the pdf file below)

Lesson 6 - Using the Autotolerancing Feature

CMC autotolerancing can be used to automatically fit a CMC ellipsoid to a standard and to calculate CIE L*a*b*, CIEL*C*h, or Hunter L, a, b tolerances for that standard based on the size and shape of that ellipsoid.  In this lesson, we will set up a job and a standard so that autotolerances will be calculated and used for that standard.

(Download the pdf file below)

FAQs for SoftKey

What is SoftKey Licensing? 

SoftKey is a software licensing program for EasyMatch QC that enables the user to license the software to work with a specific sensor. Similar to Microsoft products, the license is supplied by HunterLab and coded into the software to register the product.  Prior to December 2016, HunterLab has been using a USB hardware key system (Sentinel Key) but will be migrating to this new way of licensing software. 

 

What is a USB Sentinel Key?

HunterLab has been using the USB hardware (Sentinel Key) prior to December 2016 to activate the license of Easy Match QC.  These USB’s are often labeled ‘SafeNet’ and are required to be in the USB port when EasyMatch QC is opened.  If the USB key is removed, then an error message will appear and EasyMatch QC cannot be used.

 

The USB Sentinel key is issued for a computer installation of EasyMatch QC and can be used with a number of HunterLab sensors.

 

What is the difference between SoftKey License and the USB hardware key? 

SoftKey is a software license that is used instead of the Sentinel hardware key.  Both often take the form of a USB key. 

The SoftKey License is uniquely associated with the sensor serial number.  The SoftKey License requires activation once EasyMatch QC is installed.  To install the SoftKey License, please see the EasyMatch QC Quick Start Guide.

The Sentinel key is a USB hardware key that works with an installation of EasyMatch QC on a specific computer and must be left in the USB port to use EasyMatch QC.  This key is often labeled ‘Safenet’. The installation path for both are similar. 

How do I tell if I have SoftKey vs Sentinel Key?

All systems prior to December 2016 have the Sentinel hardware key.  After December 2016, SoftKey Licenses have been issued for new installations of EasyMatch QC.  If applicable, software package should show a license number as part of the documentation for SoftKey.  In addition, the USB included with the package should show an ‘skl’ file for SoftKey.  Otherwise the USB would be labeled ‘SafeNet’ and function as the Sentinel hardware key.

 

How do I use the SoftKey License? 

Once the SoftKey is activated, the license will function transparently to the user.  Installation and activation steps include:  1) Install EasyMatch QC, 2) Register SoftKey License, 3) Install the color measuring sensor, 4) Standardize and measure samples.  To view the current version of your software, go to EasyMatch QC>Help>About. 

 

How do I install the SoftKey License? 

To install EasyMatch QC with the Softkey License, please follow the directions in the EasyMatch QC Quick Start Guide.

 

 

How do I get help with installing the SoftKey License?

For immediate service and support 24/7, please use the support.hunterlab.com site.  For more information on the SoftKey License, please review the FAQs and the Quick Start Guide for EasyMatch QC.  If you need additional assistance, click on the "Create a Support Request" button at the top of this page.

 

What if I have been using the USB Sentinel key in the past?

If you have been using a Sentinel key with EasyMatch QC in the past and are adding a sensor to the same computer, then a SoftKey License is not required.  If, however, you are adding a new computer and sensor, then a new SoftKey License is required for the new system.

 

How do I know if I have a Sentinel Key?

If you have been using EasyMatch QC prior to December 2016, then you have a Sentinel hardware key in one of the USB ports of your computer.  Please look for this device.  If removed, then EasyMatch QC will no longer run on your computer.

I am installing a new computer with EasyMatch QC, which key do I need?

If you are installing a new version of EasyMatch QC onto a new computer and you have been running EasyMatch QC prior to December 2016, then the key is the hardware Sentinel key and it must be removed from the old system and put into the USB port of the new computer.

If you are replacing the computer system for EasyMatch QC, but have been running EasyMatch QC prior to December 2016, then the key is the hardware Sentinel key.  This key must be removed from the old system and placed into the USB port of the new computer.

If I am upgrading EasyMatch QC, can I use the USB Sentinel key that I have?

A Sentinel hardware key was issued (prior to December 2016) for an individual computer.  This key resides in one of the USB ports.  So, If you are installing a new version of Easy match QC onto the same computer, then you can continue to use the Sentinel key. 

 

If I am upgrading EasyMatch QC, can I use the USB Sentinel key that I have?

A Sentinel hardware key was issued (prior to December 2016) for an individual computer.  This key resides in one of the USB ports.  So, If you are installing a new version of Easy match QC onto the same computer, then you can continue to use the Sentinel key. 

 

I am replacing the sensor on the same computer:  which key do I use?

If you are replacing the sensor on a computer that has been running EasyMatch QC, then you have a Sentinel key and have also been sent a new SoftKey License for the new sensor.  Either key will work and the choice is up to you.

 

How do I get a SoftKey License for a 30-day trial?

To try out the EasyMatch QC software for 30 days, one can register for a temporary Softkey License.  After installation of EasyMatch QC, the 30-day trial is selected during registration.  Fill out the form and submit your information HunterLab.  The trial license is then issued for the limited period of time.

EasyMatchQC-ER Event Log Missing/Empty

Case A: Empty event log in EZMQC ER. If there is no event saved under Event Viewer/Application and services logs/EZMQC while there are EZMQC ER- relative events saved in Event Viewer/Windows. The event source details are probably not completely registered during EZMQC ER installation. (Please check detail in the attached document for this case)

The event source details are created by the EZMQC-ER CFR server(Esd21CFRPart11Server) service which runs with system privileges. If this CFR service is not registered as service due to some unknown reasons, the server runs with logged in user privileges which may not be having sufficient privileges to create the event source details in the registry. In such case where event source registration is incomplete, the event logs will be recorded in the “Window Logs” section in the system.

 To resolve this, the CFR Server needs to be registered as service using the below procedure:

Step 1: Close the EZMQC-ER application if running, then open the Task Manager and verify “Esd21CFRPart11ServerModule” is running. If it is running then end this task by clicking on EndTask button. 

Step 2: Open command prompt with administrative privileges and type “cd C:\Program Files\Common Files\HunterLab”(for 32 bit system) or “cd C:\Program Files (x86)\Common Files\HunterLab”(for 64bit System) and press enter.

Step 3: Type “Esd21CFRPart11Server.exe /service” and press enter. (This will register the service.)

Step 4: Type “net start Esd21CFRPart11Server” and press enter. (This will start the service.)

Alternatively, navigate to the folder location “C:\Program Files\Common Files\HunterLab” or “C:\Program Files (x86)\Common Files\HunterLab” then invoke the “EZMQC_Server_Start.exe” with Admin privileges to register and start the “Esd21CFRPart11Server” service.

 Now the event source details will be saved into registry, event logs will be recorded in “EasyMatchQC” under “Applications and Services Logs” section and as well as in the EZMQC-ER application.”

 

Case B: When view event log in EZMQC ER, this "Populating event log. Please wait......" dialog keeps running and no event log is showing in EZMQC ER.  However, there are events saved under Event Viewer/Application and services logs/EZMQC. In this case, please go to services and make sure that windows event log service and Esd21CFRPart11Server are running. Then start EZMQC ER to check the event log again. 

  Creating and Configuring a SQL Database

This article describes how to create and configure a SQL database for use with EasyMatch QC.  A working knowledge of SQL server is recommended for performing these steps.  A copy of SQL Server (Microsoft SQL Server is typical) should be installed first followed by EasyMatch QC, as described in the EasyMatch QC Installation Guide

  1. In SQL Server, select File > Open and choose to open the script file from the location

         For 32 bit OS: “C:\Program Files\HunterLab\EasyMatchQC\SQL Database  Script\EZMQC.sql”

         (or)

        For 64 bit OS:  “C:\Program Files (x86)\HunterLab\EasyMatchQC\SQL Database Script\EZMQC.sql”

       This is the location of the file if you installed EasyMatch QC to the default folder.  If you installed elsewhere, you will find the SQL Database Script subfolder in your installation folder.

  1. Execute the ‘EZMQC.sql’ script file and the EZMQC SQL database will be created.
  2. You can use the SQL Server to view this database and see that tables have been created within it.
  3. In the Tree View, expand the Security Branch.
  4. Right-click on Security > Logins and choose New Login.
  5. Change Default Database to EZMQC and do User Mapping to set each User with data read and write roles for the EZMQC SQL database.

creating_an_sql_database.png

 Figure 227. Creating an SQL Database

  1. Close SQL Server.
  2. On the computer where EasyMatch QC will be run, open EasyMatch QC.
  3. Select System Configuration > Options, and then Data Storage. The Data Storage Screen appears.
  4. Select the SQL Server, enter the server and database name (EZMQC). Click OK.

 sql_database_storage.png

Figure 228. SQL Database Storage

When the SQL Database Server is selected, a new option is provided to select the Authentication type as ‘Windows’ or ‘SQL server’ in the Data Storage Dialog.  If ‘Windows’ is selected, the current system login in user credentials will be used to login to the SQL server, then there is no need to specify the user name and password.  When ‘SQL Server’ option is selected, the database server credentials need to be specified.

Note: When ‘Windows Authentication’ option is selected in SQL server (local server or network server in a domain), the login security permissions should be added for the configured EZMQC-ER Admin/User groups for EZMQC database in the SQL Server.

  1. Restart EasyMatch QC and then SQL Server Database is ready for use.

 

EZMQC sentinel key activation on Win 10

If you have EZMQC Version 4.93 and before, the sentinel key would not work when you use it in Win10 build 1803 and above. We have fix this in EZMQC 4.94 and above while we do recommend all of our customer using EZMQC softkey if they have EZMQC 4.88 and above. 

Here are couple options to solve this:

* If you have EZMQC 4.88 and above, we recommend you to replace the sentinel key with softkey. If you could not find your softkey, please contact us through support@hunterlab.com

* If you have EZMQC between 4.86-4.88, we can provide you the EZMQC upgrade together with the softkey. If you do not want to change the EZMQC version, we can provide the updated dll file  to fix this EZMQC sentinel key problem in windows 10 build 1803 and above.

*If  you have EZMQC 4.86 and below, please contact us support@hunterlab.com for EZMQC upgrade. 

 

Attached, please check the updated Esdkey.dll. This DLL is updated to use the latest Sentinel SuperPro Client Library (Ver7.1.0.12) which is compatible with Windows 7 and above (including Windows 10 version 1803). 

Follow the steps here to activate this new Esdkey.dll in your windows system:  

  1. Replace the existing ‘EsdKey.dll’ file in the folder location ‘C:\Program Files\Common Files\HunterLab’.(If it is 64 bit system go to the folder location ‘C:\Program Files (x86)\Common Files\HunterLab’ ).
  2. Go to Start and type cmd, then right click on cmd and click on ‘Run as Administrator’.

cmd.jpg

     3. Type "cd C:\Program Files\Common Files\HunterLab" and press Enter. (If it is 64 bit operating system use the path “C:\Program Files (x86)\Common Files\HunterLab”). Then type “regsvr32 ESDKey.dll” and press enter. Now the EsdKey.dll will be registered successfully. 

register_esdkey.jpg

 

 

 

 

 

EZMQC Error "Unable to Change Enhanced Power Management settings"

To solve this "Unable to Change Enhanced Power Management settings", please try following steps in your windows system.

Unable_to_Change_Enhanced_Power_Management_settings.PNG

1) Open the Windows Registry editor (regedit.exe). This can be done from the “Run” command by pressing Windows+R and entering “regedit” (without the quotes) as the command.

2) Once the editor is open, expand the following key:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\USB

3) Look for the subkeys that begin with “VID_1D89”

4) For each subkey, do the following:

a. Expand the tree and select the subkey “Device Parameters”
b. Double-click on the value “EnhancedPowerManagementEnabled”
c. Set the “Value data” field to 0, click on OK

5) Close the editor.

Unable to Change Enhanced Power Management settings error message in EZMQC

Help when I try to connect to my instrument in the EasyMatch QC software I am seeing the following error message: "Unable to Change Enhanced Power Management settings"

To solve this "Unable to Change Enhanced Power Management settings", please try following steps in your windows 10.

1) Open the Windows Registry editor (regedit.exe). This can be done from the “Run” command by pressing Windows+R and entering “regedit” (without the quotes) as the command.

2) Once the editor is open, expand the following key:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\USB

3) Look for the subkeys that begin with “VID_1D89”

4) For each subkey, do the following:

a. Expand the tree and select the subkey “Device Parameters”
b. Double-click on the value “EnhancedPowerManagementEnabled”
c. Set the “Value data” field to 0, click on OK

5) Close the editor

Import QTX Format

Question: I have tried to import QTX formated data and found that if no instrument is currently connected to EasyMatchQC there is no data displayed. As soon as I connect to a sensor the data comes out. Why?

Answer:

An instrument must be connected so that EasyMatchQC knows which wavelength range and interval to use. (e.g. 400-700 @ 10, 360-780 @ 10, 350-1050 @ 5) Once the range and interval are known then the import can begin.

New ASCII design in EZMQC Version 4.92

We have changed the design of ASCII Configuration dialog in EZMQC Ver 4.92.

In previous version, users have to configure all the color scales, color indices, Text fileds, Procedure, and spectra data in ASCII Export Configuration dialog. 

Old_ASCII_Export.JPG

From Version 4.92, no more configuration on color scales, color indices, text fields, and procedures in ASCII Export Configuration. Users only need to configure the spectra data in the ASCII Export Configuration dialog if they need the spectra. All other data, Color indices, color indices, text fields, and procedures are exported if they are displayed in Color Data Table view.

New_ASCII_Configuration_dialog.png

Please note:

If you are doing the ASCII Export in EZMQC 4.92 and above, after ASCII setup and at the beginning of exporting data into a file, do not change the color data table view otherwise the exported data will be changed as well. 

If you export the formula field the latest measurement must be always showed in the bottom line of CDT view. To ensure that, please check: No "Latest data First" option applied in CDT configuration; and No samples on the top of job tree if you use standards in that job. 

How to Standardize in TTRAN Total Transmission mode in EasyMatch QC

FAQ: "We have the ColorQuest XE in our lab and are attempting to do a standardization for the TTRAN Mode for the first time. I see in the directons that the black tab is placed inside, but it doesn't clearly specify if the light trap is placed outside like for the reflectance standardization, or if that area is left exposed to ambient light. Could you please explain how it should be set up?"

Technically you always standardize where the sample is being measured. So if it is in TTRAN in the transmission compartment against the sphere, this is where you place your Light Blocker. It is a black anodized plate with a little handle on it. You can place the Light Blocker at the TTTRAN port and close the transmission using the indent in the handle to hold the Light Blocker in place in front of the transmission sphere port. This bottom-of-scale standardization step blocks light getting to the lens and on to the detector, giving the instrument a reference for what is 0% transmission.

For this Light Blocker step, it does not matter what is at the reflectance port because you are blocking light from the position of the Light Blocker forward to the lens and detector. 

Setting the top-of-scale to 100% is similar. In this case you put a white tile at the reflectance port that fills in the sphere. It stays there for all subsequent measurements because effectively, it is part of the sphere wall. What the instrument is standardizing on is what is at the TTRAN port which typically is Air for transparent solid samples like plastic plaques, or a cell of some path length filled with distilled water if measuring transparent liquids.

After successfully standardizing in TTRAN transmission, it is advised to read back the top-of-scale (Air or cell + distilled water) as a PQ Performance Qualification step. If you set it to 100% transmission, it should always read L* = 100, a* = 0, b* = 0 if you are set up correctly. If so, you are performance qualified to continue with sample measurements.

 

How can I enable login within EasyMatch QC to set User Privilege?

FAQ: "Our customer wants to establish feature privileges in EasyMatch QC software, such that operators cannot delete standards or samples. only recalibrate and measure. Can this be done?"

EasyMatch has a feature that allows customers to enable a login just for the EZMQC software package and allows customers to set privileges for different user groups to operate features of EZMQC software.

To enable login in the software go to Options/Application Preferences/Startup Defaults. In this window check the box next to Login Required. Click OK and then close and reopen the EZMQC software.

Startup Defaults tab in Application Preference window.

Upon reopening the EZMQC software you will be prompted to login. The default administrator User's Name is “admin” and the password is “hunterlab”. Once you have the EZMQC software open you will need to setup groups and users and privileges for these groups. You  can remove the default "admin" group or change the password for this group if you want to lock down this entry.

EasyMatch QC login screen.

To edit Users and Groups go to Options/System Configuration/User Manager. You will see the default admin User and EasyMatchAdmin Group. To create a new user right click on the Users folder on the left and select New User. You will need to enter a User Name, full name, and a password. In this example we will be creating a user called Operator. Click on Create after entering all information to create this user.

Adding a new User in the User Manager

New User added shown in User Manager

Now you will need to create a Group to put this user into. To create a new Group click on the Groups folder on the left then right click and select New Group. You will need to give the Group a name and a description of this group. You will then need to click on the Add button to add members to this Group. A new window will open showing you the Users you have available to add to this Group. Select the User and click Add to add them to the Group.

Adding a new Group from the User Manager

Now that you have created a Group and populated it with Users you can set privileges for the Group. To do this click on the Set Privileges button.  A window will open that shows every file and right click option. Go through all of these options and select/disable the options by placing an appropriate check to enable. A good starting point is to disable the delete option. Click OK to save these changes.  You will see a message that prompts you to close and reopen the EZMQC software. Click OK and then click the Create button to create your Group.

Setting privileges for Users added to the Group

Please restart the EZMQC software for the Access Privileges to take effect.

You will now need to close the User Manager and close the EZMQC software. When you reopen the EZMQC software you will find that the new settings have taken effect.

Group privileges can be set to display file menu item as active or grayed out.

In the case above, Edit privileges for "Cut" and "Delete" for the "Operators" group were left unchecked, resulting in the "Cut" and "Delete" features in the File Menu Edit display being grayed out and inactive. 

EasyMatchQC Connection Error

Troubleshooting generic error message about "Connection Error" displayed by EZMQC

1. after message is shown clear message, then attempt to take a new measurement, Read Standard or Read Sample. Does the Instrument measure correctly? If yes then how often does this problem occur and what action is being done immediately prior to the message? Did you notice if the lamp flashed prior to the error message? If not then the message was likely caused by a communication timeout where the software was waiting for the instrument to send data and when no data appeared in a pre-determined time frame the software quits waiting and sends the error. Inspect lamp system and Power supplies if you suspect the lamp caused a problem. Did a motor need to run (e.g. UV filter or SPIN/SPEX door) prior to measurement, if yes the motor functions, since EZMQC allows a pre-determined time frame for a motor function to complete, if the function delays we might ssee the message, then on the following measurement where the motor function is now in the correct state there is no error.

The other possibility is that is you are using a USB-to-Serial converter that the USB port on the computer is "going to sleep" and disconnecting the sensor from the software. Typically Energy Saving settings on the computer will cause the USB ports to shut down if they are not accessed in the specified time frame.